June 15, 2007

Comments and Spam

Problems or questions regarding comments or comment spam?  Ask here!

Posted by: Pixy Misa at 08:08 AM | Comments (22) | Add Comment
Post contains 13 words, total size 1 kb.

1

I think the "awaiting comments" mechanism you've set up isn't well considered. There are a number of problems with it.

First, it isn't even obvious that it's happened. The only reason I knew about that one today was because someone else noticed the number mismatch.

Second, there isn't any way for me to look at such a comment to decide whether to let it through. I have to enable it in order to see it.

I don't really see any benefit in having a three-tier system. Either delete the comment entirely as spam or let it through. But if you choose to continue with a three-tier system, there needs to be a way to directly alert the blog owner that a comment has been held, and to let them view it and decide whether to let it through.

Posted by: Steven Den Beste at July 16, 2007 09:41 PM (+rSRq)

2

That should have been "awaiting moderation", not "awaiting comments".

Posted by: Steven Den Beste at July 16, 2007 09:41 PM (+rSRq)

3 Fair enough.

First two points I agree with absolutely.  I'll address those ASAP.

Third point I'll think about.

Posted by: Pixy Misa at July 17, 2007 04:16 AM (PiXy!)

4 While you're thinking, another question

Is the "comments" folder directory (http://oldgrouch.mee.nu/edit/comment/) supposed to show all comments, or only the recent ones? Mine presently shows two comments written on July, but there are others from April and May that are still visible on the site.

Posted by: Old Grouch at July 28, 2007 03:18 PM (RkOaY)

5 Um.  Okay, that's a bug, and I know why it's happening.  Tricky to fix though...  Oh, no it isn't.  Aha!  I'll get that fixed for the next update.

Posted by: Pixy Misa at July 29, 2007 04:27 AM (PiXy!)

6 Whattheheck are you doing working on Sunday? ;-)

(Yah, I know I'm replying on Sunday, but I'm a blogger and therefore have no life...)

Posted by: Old Grouch at July 29, 2007 09:05 PM (8Iqe9)

7

Bug alert: Right now at "Ego's Nest" the top comment on the side bar has a toasted "Entry" URL. It's a comment by Wonderduck that begins "Good lord, am I a dope." The "Entry" URL is this:

http://avatar.mee.nu/641057

 I have no idea where that might have come from, but it isn't a link to anything.

Posted by: Steven Den Beste at August 14, 2007 03:21 AM (+rSRq)

8 That's actually a notabug.  It really is a working link.  My guess is that Avatar originally either left the title off that post or titled it in Japanese.  In that case, the system uses the post ID as the link, and since I loaded the Jawa Report and Ace of Spades into Minx, post IDs are indeed in the 600k range.

Posted by: Pixy Misa at August 14, 2007 07:41 PM (PiXy!)

9

My brand new Category listing files don't show comments for any of my posts. Even if I click to access the page for the post, there are no comments.

I understand why they're not inline; the category listing files are already ridiculously long. But why can't I see the comments by clicking through to the individual entries?

Posted by: Steven Den Beste at August 23, 2007 07:41 PM (+rSRq)

10

OK, I figured out something. The main page links to article pages at the root, but the category page adds an entry in the URL. So:

http://chizumatic.mee.nu/help_the_economy_spend_spend_spend

becomes

http://chizumatic.mee.nu/daily_life/help_the_economy_spend_spend_spend

The first one has comments. The second one does not.

I'm going to try changing the category definition to get rid of that extra path entry. It's set up automatically, but maybe I don't want it that way.

Posted by: Steven Den Beste at August 23, 2007 07:45 PM (+rSRq)

11 Actually, no I'm not. I'm a bit afraid to mess with it.

Posted by: Steven Den Beste at August 23, 2007 07:47 PM (+rSRq)

12 I really should investigate more before I post. It's only the posts I retroactively categorized which have this problem. But that's peculiar, because even the new posts which do show comments in the category listing still have the dual paths.

Posted by: Steven Den Beste at August 23, 2007 07:54 PM (+rSRq)

13 Another problem with categories: Try going to the bottom of this one and pressing the "more" link on the earliest post. It doesn't expand the individual post; it just redisplays the category listing.

Posted by: Steven Den Beste at August 25, 2007 03:22 AM (+rSRq)

14 I think they're all part of the same problem.  I should have a fix by tomorrow.

Posted by: Pixy Misa at August 27, 2007 01:09 AM (PiXy!)

15 Just now it took three tries to enter a comment at Teresa's. First two times tried previewing first, and it just disappeared. Third try worked by posting without preview.

Am logged on to mee.nu, but don't have cookies enabled for her site.

The preview function worked for this comment, except for the long-time bug of it blanking the "Web" field.

Posted by: Old Grouch at October 17, 2007 04:55 PM (v0+/3)

16
Am logged on to mee.nu, but don't have cookies enabled for her site.
That'll do it.
The preview function worked for this comment, except for the long-time bug of it blanking the "Web" field.
Yeah, it does that because you're logged in, and don't have a web address registered against your username.  I should fix that.

Posted by: Pixy Misa at October 25, 2007 03:26 AM (PiXy!)

17 This also might be of interest:
Who the heck is wonderduck and why is it every time I come here Minx thinks that I am it and that I'm logged in?
and
Remember when I came over here and was logged in as wonderduck? Well, I did what you suggested and logged out. Worked like a charm!

BUT now every time I come over to comment I have to again log out of that name... just something else for Pixy to work on.

More fun for the developer's copious spare time ;-)

Posted by: Old Grouch at October 29, 2007 02:22 AM (t3osk)

18 Thanks.  That is very strange.

Posted by: Pixy Misa at October 30, 2007 05:05 AM (PiXy!)

19 Just lost the old post due to my clumsy fingers.

My custom is to surf with Java and cookies off. This has saved me much trouble, and I have gotten in trouble when I forgot. I post here with both on.

Normally I right click/open in new tab the date stamp, and this works for me. While surfing Steven den Beste's site, I opened his never watch category, and then tried to open the gundum post at the top. It instead displayed the category view all over again.

While trying to replicate, I was able to access the first post in Old Grouch's Administrivia category, and the first in my lessons learned category.

Posted by: PatBuckman at November 01, 2007 12:23 AM (DZ471)

20 Yes, I think this was a bug that existed when Steven was setting up his categories; it was fixed afterwards, but left some links on Steven's site non-functional.   I'll be fixing this soon.

Posted by: Pixy Misa at November 01, 2007 02:56 AM (PiXy!)

21 It would be Very Nice Indeed if when someone on one of these blogs has comments on a subject disabled that the "add comment" link is no longer present and/or clickable on that entry.

Clicking "add comment" to get a page that says "comments disabled" is exceedingly annoying.

Posted by: Mark A. Flacy at December 24, 2008 07:08 AM (Iw3Tx)

22

Hi Pixie!

I have a regular commenter on my site from Germany who is complaining that his comments aren't getting through, but are being flagged as "awaiting moderation".  He's getting on me about it, so I thought I would ask you what is happening. I am set up for unlimited comments.  I assume this is some sort of spam filter?

Any input would be appreciated.

Thanks!

Posted by: Timothy Birdnow at May 08, 2010 12:34 PM (vhA+2)

Hide Comments | Add Comment

Comments are disabled. Post is locked.
20kb generated in CPU 0.02, elapsed 0.024 seconds.
32 queries taking 0.0094 seconds, 74 records returned.
Powered by Minx 1.1.6c-pink.